Using Archivematica Tools

From Archivematica
Jump to: navigation, search

Main Page > Documentation > Release 0.3 Documentation > Using Archivematica Tools

Contents

[edit] Location of test files

  • Test files are located in home/demo/ingest/.

[edit] Generating checksums

  • Select the files for which you would like to generate the checksums. Please note that as of the current version of Archivematica you cannot select folders, only files.
  • Right click, then select Scripts > makeMD5.
  • Save the report in the same folder.
  • Copy all the files, including the MD5 report, to another folder (eg. archivalstorage)
  • Right-click the report, then select Scripts > checkMD5
  • The report should tell you that all files are OK. If you didn't move over all the files or if there was a problem which changed one or more of the files, the report will tell you that the checksum for those files failed.

[edit] Using DROID

  • DROID provides a gui interface for selecting objects for processing. Navigate to home/demo/ingest/ and select the entire folder, or open the folder to select individual files.
  • DROID allows you to select an "include subfolders" option.
  • When the files are processed, go to File > Save List to save an xml report of the results.

[edit] Using NLNZ Metadata Extraction Tool

  • Creating a simple object will result in one xml report for each object; creating a complex object will create a single report for all objects.
  • When you create a new object in NLNZ, you will be asked to select the directory: enter /home/demo/ingest/.
  • The xml reports are set to output to usr/local/OAIS/metadata-extractor/harvested/nlnz_dd/.

[edit] Using JHOVE

  • To include calculation of checksums in the validation process, go to Edit > Preferences and click Calculate checksums.
  • To process a directory of records, click File > Open URL and enter the directory: /home/demo/ingest/.
  • To save an xml report, in the RepInfo window click on File > Save as; under Choose output handler select xml; then create a file name with the .xml extension added (otherwise JHOVE will save the report as plain text).

[edit] Using Qubit

  • Qubit is an open-source software toolkit that allows institutions such as archives, libraries, museums, and art galleries to manage and host web-based collections of information resources.
    • It is currently being implemented in the archival community as ICA-AtoM (International Council on Archives Access to Memory).
      • Please refer to the ICA-AtoM user manual for instructions on how to use a typical Qubit application.
  • Qubit is being evaluated for use in the archivematica Data Management and Access components.
  • Please note that the VM version of Qubit is a development version, not a stable release.
  • Log in to Qubit using the user name demo@example.com and the password demo.

[edit] Using Xena

  • Click Add Directory to normalize a body of records.
  • Select home/demo/ingest. Note that Xena will normalize the contents of the folder and any subfolders.
  • The default directory for Xena output is home/demo/xena-output/.
  • The Xena log will save automatically as home/demo/xena-output/xena-log.
  • To view a normalized file, double-click on a file in the normalization results screen. For office documents, you will then need to select the option to view in OpenOffice.org.
    • If OpenOffice.org appears not to be working or takes a long time to open, go to Tools > Plugin Preferences >, and for "Sleep time allowed for OpenOffice to start (seconds)" select 3.

[edit] Using Bagit

  • Select a group of files or a folder.
  • Right-click, then select Scripts > Bagit.
  • Edit the name of the bag if desired.
  • The bag will automatically be saved to home/demo/mybags/.
Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox