LiveDVD

From Archivematica
Jump to: navigation, search

Main Page > Projects > Vancouver Digital Archives > Archivematica > LiveDVD

[edit] Software on the LiveDVD (release 0.1)

  • DROID version 3.0
  • JHOVE version 1.1
  • NLNZ Metadata Extractor version 3.0
  • md5sum scripts (makeMD5 and checkMD5) version 1.0
  • Ubuntu EXT3 filesystem version 8.0.4
  • Qubit version 1.0.5-dev

[edit] Instructions for using LiveDVD

1. Start the LiveDVD

  • Insert the dvd into your computer's CD/DVD drive.
  • Turn off the computer.
  • Turn the computer back on: the computer will boot from the dvd. If this doesn't happen, turn the computer off, start it up again and press F12 to boot from the dvd.
  • Note that you will have access to the Internet via Mozilla Firefox when you are in the LiveDVD environment.

2. Location of test files

  • Test files are located in home/ubuntu/ingest.

3. Generating checksums

  • Select the files for which you would like to generate the checksums. Please note that as of Qubit-OAIS 0.1 you cannot select folders, only files.
  • Right click, then select Scripts > makeMD5.
  • Save the report in the same folder.
  • Copy all the files, including the MD5 report, to another folder (eg. archivalstorage)
  • Right-click the report, then select Scripts > checkMD5
  • The report should tell you that all files are OK. If you didn't move over all the files or if there was a problem which changed one or more of the files, the report will tell you that the checksum for those files failed.

4. Using DROID

  • DROID provides a gui interface for selecting objects for processing. Navigate to home/ubuntu/ingest/ and select the entire folder, or open the folder to select individual files.
  • DROID allows you to select an "include subfolders" option.
  • When the files are processed, go to File > Save List to save an xml report of the results.

5. Using NLNZ Metadata Extraction Tool

  • Creating a simple object will result in one xml report for each object; creating a complex object will create a single report for all objects.
  • When you create a new object in NLNZ, you will be asked to select the directory: enter /home/ubuntu/ingest/.
  • The xml reports are set to output to usr/local/OAIS/metadata-extractor/harvested/nlnz_dd/.

6. Using JHOVE

  • To include calculation of checksums in the validation process, go to Edit > Preferences and click Calculate checksums.
  • To process a directory of records, click File > Open URL and enter the directory: /home/ubuntu/ingest/.
  • To save an xml report, in the RepInfo window click on File > Save as; under Choose output handler select xml; then create a file name with the .xml extension added (otherwise JHOVE will save the report as plain text).

7. Using Qubit

  • Qubit is an open-source software toolkit that allows institutions such as archives, libraries, museums, and art galleries to manage and host web-based collections of information resources.
    • It is currently being implemented in the archival community as ICA-AtoM (International Council on Archives Access to Memory).
      • Please refer to the ICA-AtoM user manual for instructions on how to use a typical Qubit application
  • Qubit is being evaluated for use in the OAIS Data Management and Access components
  • Please note that the LiveDVD version of Qubit is a development version, not a stable release.

[edit] LiveDVD release versions

  • release 0.1: oaisdvd-200903270.iso
Personal tools
Namespaces

Variants
Actions
Navigation
Toolbox